Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
InputOne N in one line, process to the end of file.
OutputFor each N, output N! in one line.
Sample Input1 2 3
Sample Output1 2 6
#include <iostream>
using namespace std;
int main()
{
int n;
while(cin>>n)
{
int a[50000]={0},i,j,digit=1;
a[0]=1;
for(i=2;i<=n;++i)
{
int count;
for(j=1,count=0;j<=digit;++j)
{
int s=a[j-1]*i+count;
a[j-1]=s%10;
count=s/10;
}
while(count)
{
a[++digit-1]=count%10;
count/=10;
}
}
for(i=digit;i>=1;i--)
{
cout<<a[i-1];
}
cout<<endl;
} return 0;
}
InputOne N in one line, process to the end of file.
OutputFor each N, output N! in one line.
Sample Input1 2 3
Sample Output1 2 6
#include <iostream>
using namespace std;
int main()
{
int n;
while(cin>>n)
{
int a[50000]={0},i,j,digit=1;
a[0]=1;
for(i=2;i<=n;++i)
{
int count;
for(j=1,count=0;j<=digit;++j)
{
int s=a[j-1]*i+count;
a[j-1]=s%10;
count=s/10;
}
while(count)
{
a[++digit-1]=count%10;
count/=10;
}
}
for(i=digit;i>=1;i--)
{
cout<<a[i-1];
}
cout<<endl;
} return 0;
}